Percolate Unavailable

Incident Report for Percolate

Resolved

This incident has been resolved.
Posted Aug 26, 2021 - 15:58 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2021 - 15:41 EDT

Investigating

We are experiencing an issue where users are unable to access Percolate. Will update status in the next hour.
Posted Aug 26, 2021 - 15:23 EDT
This incident affected: Percolate Application.