Percolate Login Page Unavailable

Incident Report for Percolate

Resolved

Access to the login page has been restored.
Posted May 14, 2025 - 18:28 EDT

Investigating

The Percolate login page is currently unavailable. Our team is aware of the issue and actively triaging the behavior. We will provide updates as soon as more information becomes available.
Posted May 14, 2025 - 18:15 EDT
This incident affected: Percolate Website.